KK's Detailed Modding Tutorial

Discuss and distribute tools and methods for modding. Moderator - Grognak
User avatar
Jumbocarrot0
Posts: 402
Joined: Sat Oct 21, 2017 1:18 am
Location: My current location.

Re: KK's Detailed Modding Tutorial

Postby Jumbocarrot0 » Thu Apr 12, 2018 4:07 am

Honestly it would be hard for any non-human to use computers. Lanius would probably just eat it by instinct, rockmen's and crystalmen's hands are too big for the keyboard and zoltan would probably overcharge the computer.
Image
User avatar
TheSubsetGamer
Posts: 9
Joined: Thu Jul 12, 2018 3:04 pm

Re: KK's Detailed Modding Tutorial

Postby TheSubsetGamer » Fri Sep 14, 2018 7:31 pm

This tutorial is quite helpful, however I was wondering what I would do if I was using GOG instead of Steam
Thanks fellow gamers!
User avatar
KingdomKrafters
Posts: 134
Joined: Sat Oct 28, 2017 8:09 pm
Location: Somewhere in Murica

Re: KK's Detailed Modding Tutorial

Postby KingdomKrafters » Tue Sep 25, 2018 8:00 pm

To be honest I have no clue. I didn't even know there was another way to get FTL other than Steam (except on mobile of course)... I suppose you would probably use the same method but you would have to find a different directory? Not really sure. :| Sorry.
Image
KeyChain
Posts: 2
Joined: Sun Jun 23, 2019 3:20 am

Re: KK's Detailed Modding Tutorial

Postby KeyChain » Sun Jun 23, 2019 3:44 am

So I don't know if this is the best place to ask but is there a way to create a laser weapon with an accuracy drop? I'm trying to create a weapon that will fire off 5 shots but has a chance of missing like a flak gun. I know it's possible, I've pulled it off before a while back on my old computer about a month back but I'm having trouble recreating it. I run into one of two problems when making the mod. The first is that the blueprint reads <shots>5</shots> but when examining the weapon in game or via Super Luminal it insists there is, in fact, 0 shots. (This isn't just a visual error either, when the weapon fires in-game nothing happens.) The second issue is that I get the weapon to fire but then the weapon has pinpoint accuracy.

Now the blueprint looked something like this from what I can remember. Any idea what I'm doing wrong or, more importantly, how it can be done?

Code: Select all

<weaponBlueprint name="LASER_BURST_5">
   <type>BURST</type>
   <title>Burst Laser Mark IV</title>
   <short>Burst Laser IV</short>
   <desc>Powerful burst laser that fires off an impressive barrage at the cost of accuracy.</desc>
   <tooltip>Fires 5 lasers; 1 damage per shot.</tooltip>
   <damage>1</damage>
   <shots>5</shots>
   <sp>0</sp>
   <fireChance>1</fireChance>
   <breachChance>1</breachChance>
   <cooldown>20</cooldown>
   <power>4</power>
   <cost>95</cost>
   <projectiles>
      <projectile count="1" fake="false">laser_light2</projectile>
   </projectiles>
   <radius>32</radius>
   <bp>10</bp>
   <rarity>4</rarity>
   <image>laser_light2</image>
   <launchSounds>
      <sound>lightLaser1</sound>
      <sound>lightLaser2</sound>
      <sound>lightLaser3</sound>
   </launchSounds>
   <hitShipSounds>
      <sound>hitHull2</sound>
      <sound>hitHull3</sound>
   </hitShipSounds>
   <hitShieldSounds>
      <sound>hitShield1</sound>
      <sound>hitShield2</sound>
      <sound>hitShield3</sound>
   </hitShieldSounds>
   <missSounds>
      <sound>miss</sound>
   </missSounds>
   <weaponArt>laser_burst_5</weaponArt>
</weaponBlueprint>
User avatar
KingdomKrafters
Posts: 134
Joined: Sat Oct 28, 2017 8:09 pm
Location: Somewhere in Murica

Re: KK's Detailed Modding Tutorial

Postby KingdomKrafters » Tue Jun 25, 2019 8:43 pm

Well you are doing the correct thing by making it a "BURST" weapon. I can't quite make out what the issue might be, but I attempted this myself and included the file in this post, hopefully this works for you.

Also sorry for the late response, I only check the forums occasionally. Hopefully its not to late.
https://www.dropbox.com/s/jxk8z4jky1lcu ... e.ftl?dl=0
Image
KeyChain
Posts: 2
Joined: Sun Jun 23, 2019 3:20 am

Re: KK's Detailed Modding Tutorial

Postby KeyChain » Sun Jan 19, 2020 7:53 am

Alright, back again with a new problem with modding. I don't have a lot of time in my life to do it but I've sort gotten more interested in it. That said, I come across new problems. The weapon we chatted about before now works perfectly (thanks to you) and does "appear" in game, however, a problem I'm having now has to do with weapon sprite not showing up.

I think it's just me not fully understanding how I do the animations (for example I have no idea what the 'charge' in the firepoint tag does) but this is what I have so far. (Note what is posted below is EXACTLY what is written (and how it is written) in the xml files, nothing more, nothing less. Also note that the sprite file is a PNG image and is simply named "laser_burst_6". Don't know if there is something specific I should be naming it.)

Animation:

Code: Select all

<animSheet name="laser_burst_6" w="780" h="125" fw="51" fh="124">weapons/laser_burst_6</animSheet>
<weaponAnim name="laser_burst_6">
   <sheet>laser_burst_6</sheet>
   <desc length="15" x="0" y="0"/>
   <chargedFrame>9</chargedFrame>
   <fireFrame>10</fireFrame>
   <firePoint  x="32" y="3" charge=""/>
   <mountPoint x="0" y="72"/>
</weaponAnim>


BluePrint:

Code: Select all

<weaponBlueprint name="LASER_BURST_6">
   <type>BURST</type>
   <title>Burst Laser Mark IV</title>
   <short>Burst Laser IV</short>
   <tip>tip_laser</tip>
   <desc>Ludicrously powerful burst laser that fires off an insane volley at the cost of accuracy.</desc>
   <tooltip>Fires 7 lasers; 1 damage per shot.</tooltip>
   <damage>1</damage>
   <shots>7</shots>
   <radius>42</radius>
   <spin>0</spin>
   <sp>1</sp>
   <hullBust>1</hullBust>
   <fireChance>2</fireChance>
   <breachChance>2</breachChance>
   <stunChance>2</stunChance>
   <cooldown>40</cooldown>
   <power>4</power>
   <cost>125</cost>
   <bp>10</bp>
   <rarity>5</rarity>
   <image>laser_burst_6</image>
   <projectiles>
      <projectile count="1" fake="false">laser_light2</projectile>
   </projectiles>
   <launchSounds>
      <sound>lightLaser1</sound>
      <sound>lightLaser2</sound>
      <sound>lightLaser3</sound>
   </launchSounds>
   <hitShipSounds>
      <sound>hitHull2</sound>
      <sound>hitHull3</sound>
   </hitShipSounds>
   <hitShieldSounds>
      <sound>hitShield1</sound>
      <sound>hitShield2</sound>
      <sound>hitShield3</sound>
   </hitShieldSounds>
   <missSounds>
      <sound>miss</sound>
   </missSounds>
   <weaponArt>laser_burst_6</weaponArt>
   <iconImage>laser</iconImage>
</weaponBlueprint>


Don't know if this is needed but this is the sprite in question.
https://imgur.com/beCL5LZ
User avatar
KingdomKrafters
Posts: 134
Joined: Sat Oct 28, 2017 8:09 pm
Location: Somewhere in Murica

Re: KK's Detailed Modding Tutorial

Postby KingdomKrafters » Fri Jan 24, 2020 10:21 pm

Sorry my reply is a little late, I rarely check the forums now-a-days.

Your problem is rather simple, if I'm seeing it correctly.

you should have .png after the weapon's name in the anim sheet like this:
<animSheet name="laser_burst_6" w="780" h="125" fw="51" fh="124">weapons/laser_burst_6.png</animSheet>
<weaponAnim name="laser_burst_6">
<sheet>laser_burst_6</sheet>
<desc length="15" x="0" y="0"/>
<chargedFrame>9</chargedFrame>
<fireFrame>10</fireFrame>
<firePoint x="32" y="3" charge=""/>
<mountPoint x="0" y="72"/>
</weaponAnim>

Hopefully that should fix it.

Its rather hard to respond/co-ordinate on the forums, so if you have any future questions and want a response in something quicker than a 5 day timespan, I recommend joining the FTL discord, where you can contact me at Puffias Leroy McBillington III#1234

https://discord.gg/btqm3cY
Image
MrKrySss
Posts: 1
Joined: Thu Jun 11, 2020 8:13 pm

Re: KK's Detailed Modding Tutorial

Postby MrKrySss » Thu Jun 11, 2020 8:26 pm

Hello, I'm not really new to modding but FTL is quite tricky. I don't make mods but rather adjust existing ones for myself i.e. numbers, sprites. So I ran into a problem with sprites and I dont quite know what I did wrong or if I didn't do something all together. The sprites I'm talking about are for the interiors. I used superluminal, I made a couple of 1x3, 1x4 and 2x4 rooms and made sprites to fit them. Everything seems to be working fine except that the sprites show yellow warning signs in game. In superluminal everything looks fine.
User avatar
RAD-82
Posts: 788
Joined: Sat Nov 09, 2013 12:16 am
Location: Not where a person needs to be...

Re: KK's Detailed Modding Tutorial

Postby RAD-82 » Fri Jun 12, 2020 1:25 am

MrKrySss wrote:Hello, I'm not really new to modding but FTL is quite tricky. I don't make mods but rather adjust existing ones for myself i.e. numbers, sprites. So I ran into a problem with sprites and I dont quite know what I did wrong or if I didn't do something all together. The sprites I'm talking about are for the interiors. I used superluminal, I made a couple of 1x3, 1x4 and 2x4 rooms and made sprites to fit them. Everything seems to be working fine except that the sprites show yellow warning signs in game. In superluminal everything looks fine.

Are your .png files interlaced? FTL only supports non-interlaced .png files.

I don't know if this is the issue, because the last time I saw someone have issues with interlaced .png files, they only mentioned things being invisible rather than seeing the yellow warning signs.
Image
Junkyard has FTL mods, mostly ships and a few other things.

Who is online

Users browsing this forum: No registered users and 7 guests