Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Discuss and distribute tools and methods for modding. Moderator - Grognak
Grognak
Posts: 172
Joined: Tue Sep 18, 2012 9:42 pm

Re: Grognak's Mod Manager

Postby Grognak » Thu Sep 20, 2012 5:59 am

aedyr wrote:
Grognak wrote:That is strange, since it works on my end. Can you upload your .ftl file?


Well, on a whim I rewrote my xml file from scratch. Works perfectly now, as an APPEND file. Some artifact must have crept into my original. Thanks again for helping. And thanks for the tool in general; I think it's very slick.


Man, you had me racking and racking my brain as to why it wasn't working! I figured it out as well, even uploaded it, although I guess you don't need it any more. :P
Alblaka
Posts: 98
Joined: Thu Sep 20, 2012 1:41 pm

Re: Grognak's Mod Manager

Postby Alblaka » Thu Sep 20, 2012 2:00 pm

First of all, great work and a smart system of merging mods via merely appending stuff. However, I've a slight issue with using the ModManager.

I'm using the normal fldat to edit and pack data.dat's myself and so far didn't have any trouble. Test-wise, I used a fresh data.dat, and merely added a second entry of the Kestrel shipBlueprint to the end of the file, changing it's name into 'The Testrel'.
Works.

HOWEVER, if I now put the same content into a blueprints.xml.append, zip i according to the ftl-file-structure and have your Mod Manager install it, FTL will not load but crash.
Figuring out something was wrong, I then took the data.dat created by your ModManager and unpacked it again.
This is the code I found at the end of the blueprint.xml file:

Code: Select all

'<shipBlueprint name="PLAYER_SHIP_HARD" layout="kestral" img="kestral">
   <class>Kestrel Cruiser</class>
   <name>The Testrel</name>
   <desc>This class of ship was decommissioned from Federation service years ago.  After a number of refits and updating this classic ship is ready for battle.</desc>
   <systemList>
      <pilot power="1" room="0" start="true" img="room_pilot">
         <slot>
            <direction>right</direction>
            <number>0</number>
         </slot>
      </pilot>
      <doors power="1" room="2" start="true" img="room_doors"/>
      <sensors power="1" room="3" start="true" img="room_sensors"/>
      <medbay power="1" room="4" start="true" img="room_medbay">
         <slot>
            <number>1</number>
         </slot>
      </medbay>
      <oxygen power="1"  room="13" start="true" img="room_oxygen"/>
      <shields power="2" room="5" start="true" img="room_shields"/>
      <engines power="2" room="14" start="true" img="room_engines"/>
      <weapons power="3" room="10" start="true" img="room_weapons"/>
      <drones power="2" room="1" start="false"/>
      <teleporter power="1" room="15"   start="false"/>
      <cloaking power="1" room="8" start="false"/>
   </systemList>
   <weaponSlots>4</weaponSlots>
   <droneSlots>2</droneSlots>
   <weaponList count="2" missiles="8">
      <weapon name="MISSILES_2_PLAYER"/>
      <weapon name="LASER_BURST_3"/>
   </weaponList>
   <health amount="30"/>
   <maxPower amount ="8"/>
   <crewCount amount = "3" class="human"/>
</shipBlueprint>


The issue is, most likely, the ' symbol in front of the <shipBlueprint>. I've got no clue why your Mod Manager adds that character in front of the actual file content, though (it's not present in the .appends file and removing (and ftldat repacking) resolves the crash issue).

I'm currently guessing it's some sort of file corruption or eventually a UTF-8 related issue and trying to figure out a workaround.


edit: I've added a few lines and a <!-- TEST --> in front of the given code and the artifact-character is gone. I assume it's eventually something related to file-start symbols or similar, given quite everyone is using <!-- MOD NAME --> in front of his files either way.
Greetz,
Alblaka
Grognak
Posts: 172
Joined: Tue Sep 18, 2012 9:42 pm

Re: Grognak's Mod Manager

Postby Grognak » Thu Sep 20, 2012 2:25 pm

That's really odd. Thanks for the report, I'll look into it.
quxudica
Posts: 6
Joined: Sun Sep 16, 2012 12:02 am

Re: Grognak's Mod Manager

Postby quxudica » Thu Sep 20, 2012 2:42 pm

Having an odd error, everything works up to selecting the mods, then in the cmd txt box it says something close to "error permission to access data.dat denied", hard to tell the actual wording as it auto-closes soon after.
Grognak
Posts: 172
Joined: Tue Sep 18, 2012 9:42 pm

Re: Grognak's Mod Manager

Postby Grognak » Thu Sep 20, 2012 2:45 pm

quxudica wrote:Having an odd error, everything works up to selecting the mods, then in the cmd txt box it says something close to "error permission to access data.dat denied", hard to tell the actual wording as it auto-closes soon after.

What operating system are you using?

Do you have the permission level to edit inside the FTL folder in the first place?
KnMn
Posts: 7
Joined: Fri Sep 14, 2012 8:52 am
Location: Scotland
Contact:

Re: Grognak's Mod Manager

Postby KnMn » Thu Sep 20, 2012 3:03 pm

This is really great. Thank you, Grognak.
Image
quxudica
Posts: 6
Joined: Sun Sep 16, 2012 12:02 am

Re: Grognak's Mod Manager

Postby quxudica » Thu Sep 20, 2012 3:03 pm

Grognak wrote:
quxudica wrote:Having an odd error, everything works up to selecting the mods, then in the cmd txt box it says something close to "error permission to access data.dat denied", hard to tell the actual wording as it auto-closes soon after.

What operating system are you using?

Do you have the permission level to edit inside the FTL folder in the first place?


Windows 7 32 bit, yeah I am the system administrator (and only user) for this computer. I tried running the modman.exe as admin to no success.

I used screen cap to see the exact error since the cmd box was closing so fast, the line is: IOError: [Errno 13] Permission denied: 'data.dat'
Last edited by quxudica on Thu Sep 20, 2012 3:08 pm, edited 1 time in total.
keyzcz
Posts: 21
Joined: Fri Sep 14, 2012 6:20 pm

Re: Grognak's Mod Manager

Postby keyzcz » Thu Sep 20, 2012 3:04 pm

Where can i find more mods?
I would like use "Slow Rebel Movement"

This forum do not have search?!So it is difficult to find something and be still young.
KnMn
Posts: 7
Joined: Fri Sep 14, 2012 8:52 am
Location: Scotland
Contact:

Re: Grognak's Mod Manager

Postby KnMn » Thu Sep 20, 2012 3:06 pm

keyzcz wrote:Where can i find more mods?

Any topic in the Discussion forum tagged with [MOD]
This forum do not have search?!

Search is hidden away down on the bottom left of the this page inbetween 'FAQ' and 'Members'.
Image
dracul104
Posts: 2
Joined: Thu Sep 20, 2012 2:06 am

Re: Grognak's Mod Manager

Postby dracul104 » Thu Sep 20, 2012 3:34 pm

Grognak wrote:Whoops! Check out the latest version, it comes with a couple more files and a readme in the src folder.


Thanks Grognak! It's working great now!

Who is online

Users browsing this forum: No registered users and 19 guests