Page 1 of 1

Linux crash on start

Posted: Thu Dec 27, 2018 6:33 pm
by zapwai
I'm using Slackware 14.2 with the steam client for linux.
I have nvidia 4.10.73, which is up to date.
(I'm not sure how long FTL hasn't been running, it could have been a year or more.)

I get a segmentation fault as soon as the FTL window pops open.
I'm not sure what to try. Slackware uses pulseaudio, and it looks like FTL crashes right after "Starting audio library".

Last few lines of FTL.log are:

Code: Select all

ib/SIL/src/sysdep/opengl/graphics.c:471(opengl_init):    OPENGL_FEATURE_VERTEX_ATTRIB_INT
lib/SIL/src/sysdep/opengl/graphics.c:474(opengl_init): OpenGL texture formats supported: 0x37
lib/SIL/src/sysdep/opengl/graphics.c:477(opengl_init):    OPENGL_FORMAT_BGRA
lib/SIL/src/sysdep/opengl/graphics.c:477(opengl_init):    OPENGL_FORMAT_BITREV
lib/SIL/src/sysdep/opengl/graphics.c:477(opengl_init):    OPENGL_FORMAT_INDEX32
lib/SIL/src/sysdep/opengl/graphics.c:477(opengl_init):    OPENGL_FORMAT_RG
lib/SIL/src/sysdep/opengl/graphics.c:477(opengl_init):    OPENGL_FORMAT_S3TC
Video Initialized
Renderer: OpenGL version 4.6 (GL_VERSION: 4.6.0 NVIDIA 410.73)
Creating FBO...
Starting audio library...

Re: Linux crash on start

Posted: Thu Dec 27, 2018 11:43 pm
by zapwai
It was my .audiorc file, thanks isla.

https://subsetgames.com/forum/viewtopic.php?t=32404

isla wrote:The last time it came up, it turns out their .asoundrc file was not selecting the correct default alsa device (Pulseaudio). At this point, I would highly recommend updating your drivers, just to see if that changes anything immediately.

Yet another possibility, if you are using Pulseaudio, which someone brought to our attention about a month ago is applying the following to ~/.asoundrc (in your home directory/wherever Steam is if you are using Steam):

pcm.!default {
type pulse
hint.description "Default Audio Device"
}

ctl.!default {
type pulse
}

Put simply, the game wants to use ALSA, and may be defaulting to not use Pulseaudio.