Linux Sound Issue (Choppy)

Discuss problems related to FTL here. If you are having a problem or experiencing a bug PLEASE READ THE "MUST READ" POST.
mo0ep
Posts: 3
Joined: Wed Jul 24, 2013 7:43 pm

Linux Sound Issue (Choppy)

Postby mo0ep » Wed Jul 24, 2013 9:03 pm

Hey there,

First off I am running and AMD 64 x2 5600+ with an Nvidia Geforce 9800GT with ArchLinux 64-Bit with Gnome 3 and FTL v1.03.3 is installed through Steam.

Now to the Issue, the sound is getting very choppy after a while of playing FTL. It usually happens after playing for...I would say about at least 15 minutes and most of the times after losing a game, when the music changes from battle music to the menu theme (though also happens randomly while playing).

Besides the audio getting very choppy my computer also starts getting laggy and the ALSA level indicator in the Pulseaudio interface keeps flashing but is not visible most of the time (as if ALSA would be getting closed and restarted really fast). Also i noticed that the CPU usage of Pulseaudio gets up to 30% with FTL taking up another 30%.

I get rid of the issue by restarting the game, which most of the times fixes it (though not always). Another way I got rid of it was by switching to another terminal where I'm not logged in and back.

I started the game in a Terminal window once but when I ran into the issue there weren't any messages in the Terminal as to what may be causing the problem. I also turned frame limit and Vsync on since I read somewhere that those settings might cause high CPU usage, but that didn't solve the issue.

At last here are some packagees and version numbers I thought might be of significance:

extra/alsa-lib 1.0.27.2-1
extra/alsa-plugins 1.0.27-1
extra/alsa-utils 1.0.27.1-2
multilib/lib32-alsa-lib 1.0.27.2-1
extra/libcanberra-pulse 0.30-4
extra/pulseaudio-alsa 2-2
extra/pulseaudio 4.0-2



Though it's not really a major issue it would be really nice if someone could look into it.

mo0ep
boa13
Posts: 829
Joined: Mon Sep 17, 2012 11:42 pm
Location: Nantes, France

Re: Linux Sound Issue (Choppy)

Postby boa13 » Thu Jul 25, 2013 11:27 am

Can you post the output of the game when you start it from the command line? Also, anything you could find in the logs in the game directory.

What sound chip / card do you have? Can you post the output of the lspci command?
Forum janitor — If you spot spam, PM me the URL and/or the username of the spammer.
I have powers, moderator powers. I am not keen on using them, but will do so if needed.
mo0ep
Posts: 3
Joined: Wed Jul 24, 2013 7:43 pm

Re: Linux Sound Issue (Choppy)

Postby mo0ep » Thu Jul 25, 2013 12:18 pm

Here is the terminal output whilst running the game

Code: Select all

Loading Arch = amd64
Initializing Crash Catcher...
Initializing Video
Video Initialized
Opengl version = 3.3.0 NVIDIA 319.32
Starting audio library...
Audio Initialized!
Resource Preload: 8267
Initializing animations...
Animations Initialized!
Loading Ship Blueprints....
Blueprints Loaded!
Initializing Sound Data....
Generating world...
Loading achievements...
Loading score file...
Running Game!


lspci lists the following

Code: Select all

00:00.0 RAM memory: NVIDIA Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: NVIDIA Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: NVIDIA Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: NVIDIA Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB controller: NVIDIA Corporation MCP61 USB 1.1 Controller (rev a2)
00:02.1 USB controller: NVIDIA Corporation MCP61 USB 2.0 Controller (rev a2)
00:04.0 PCI bridge: NVIDIA Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: NVIDIA Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: NVIDIA Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: NVIDIA Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: NVIDIA Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: NVIDIA Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: NVIDIA Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: NVIDIA Corporation MCP61 PCI Express bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
02:00.0 VGA compatible controller: NVIDIA Corporation G92 [GeForce 9800 GT] (rev a2)


Also I use a Logitech G930 wireless headset, but I tried it with the sound on my regular (onboard on mainboard NF520-A2) soundcard and the issue was still reproduceable. Changing to an inactive (not connected) audio output and back fixes it (haven't tried changing from one connected output to another yet e.g. g930 to speakers)

As for the logs, I don't really know where they are supposed to be, I coulnd't find anything that looked like logs in the ~/.steam/steam/SteamApps/common/FTL Faster Than Light/ directory.
boa13
Posts: 829
Joined: Mon Sep 17, 2012 11:42 pm
Location: Nantes, France

Re: Linux Sound Issue (Choppy)

Postby boa13 » Fri Jul 26, 2013 11:09 am

I did some Google searches about "NVIDIA MCP61 HDA", but did not find anything particularly relevant.

Your issue looks like it happens at a lower level than FTL itself. The start log shows that everything seems fine from the FTL point of view.

Do you get this sound issue with other software (other games, video players)?

Do you have anything strange in the system logs (most likely stored in /var/log)?

To really troubleshoot the issue one would need to go deep in PulseAudio and ALSA, but I don't know how you can get them to log the details of what is happening (and it would be verbose and slow the machine down, probably). :?
Forum janitor — If you spot spam, PM me the URL and/or the username of the spammer.
I have powers, moderator powers. I am not keen on using them, but will do so if needed.
mo0ep
Posts: 3
Joined: Wed Jul 24, 2013 7:43 pm

Re: Linux Sound Issue (Choppy)

Postby mo0ep » Fri Jul 26, 2013 4:55 pm

I didn't experience this in any other program yet, though it seems to be as you said, a lower level problem. In the /var/log/ folder were no logs that i could connect to audio at all.
I did however run "pulseaudio -vvv" which is I believe debug mode or something similar. In the log that i got from that as soon as the sound gets choppy the log gets flooded with the following messages:

Code: Select all

D: [pulseaudio] core.c: Hmm, no streams around, trying to vacuum.
D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Core1.Stream removed from object /org/pulseaudio/core1/playback_stream264
I: [pulseaudio] sink-input.c: Freeing input 264 "ALSA Playback"
I: [pulseaudio] module-stream-restore.c: Restoring device for stream sink-input-by-application-name:ALSA plug-in [FTL].
D: [pulseaudio] module-intended-roles.c: Not setting device for stream ALSA Playback, because already set.
I: [pulseaudio] sink-input.c: Trying to change sample rate
I: [pulseaudio] module-stream-restore.c: Restoring mute state for sink input sink-input-by-application-name:ALSA plug-in [FTL].
D: [pulseaudio] module-suspend-on-idle.c: Sink alsa_output.usb-Logitech_Logitech_G930_Headset-00-Headset.iec958-stereo becomes busy, resuming.
I: [pulseaudio] resampler.c: Forcing resampler 'copy', because of fixed, identical sample rates.
I: [pulseaudio] resampler.c: Using resampler 'copy'
I: [pulseaudio] resampler.c: Using s16le as working format.
D: [pulseaudio] resampler.c: Resampler:
D: [pulseaudio] resampler.c:   rate 44100 -> 44100 (method copy),
D: [pulseaudio] resampler.c:   format float32le -> s16le (intermediate s16le),
D: [pulseaudio] resampler.c:   channels 2 -> 2 (resampling 2)
D: [pulseaudio] memblockq.c: memblockq requested: maxlength=33554432, tlength=0, base=4, prebuf=0, minreq=1 maxrewind=0
D: [pulseaudio] memblockq.c: memblockq sanitized: maxlength=33554432, tlength=33554432, base=4, prebuf=0, minreq=4 maxrewind=0
I: [pulseaudio] sink-input.c: Created input 265 "ALSA Playback" on alsa_output.usb-Logitech_Logitech_G930_Headset-00-Headset.iec958-stereo with sample spec float32le 2ch 44100Hz and channel map front-left,front-right
I: [pulseaudio] sink-input.c:     media.name = "ALSA Playback"
I: [pulseaudio] sink-input.c:     application.name = "ALSA plug-in [FTL]"
I: [pulseaudio] sink-input.c:     native-protocol.peer = "UNIX socket client"
I: [pulseaudio] sink-input.c:     native-protocol.version = "28"
I: [pulseaudio] sink-input.c:     application.process.id = "1123"
I: [pulseaudio] sink-input.c:     application.process.user = "fabian"
I: [pulseaudio] sink-input.c:     application.process.host = "QUASAR"
I: [pulseaudio] sink-input.c:     application.process.binary = "FTL"
I: [pulseaudio] sink-input.c:     application.language = "C"
I: [pulseaudio] sink-input.c:     window.x11.display = ":0"
I: [pulseaudio] sink-input.c:     application.process.machine_id = "fd99aa52db0f4aa6b393c3b235eef24c"
I: [pulseaudio] sink-input.c:     application.process.session_id = "1"
I: [pulseaudio] sink-input.c:     module-stream-restore.id = "sink-input-by-application-name:ALSA plug-in [FTL]"
I: [pulseaudio] protocol-native.c: Requested tlength=40,00 ms, minreq=10,00 ms
D: [pulseaudio] protocol-native.c: Early requests mode enabled, configuring sink latency to minreq.
D: [pulseaudio] protocol-native.c: Requested latency=10,00 ms, Received latency=26,00 ms
D: [pulseaudio] memblockq.c: memblockq requested: maxlength=4194304, tlength=27520, base=8, prebuf=3528, minreq=9168 maxrewind=0
D: [pulseaudio] memblockq.c: memblockq sanitized: maxlength=4194304, tlength=27520, base=8, prebuf=3528, minreq=9168 maxrewind=0
I: [pulseaudio] protocol-native.c: Final latency 104,00 ms = 26,03 ms + 2*25,99 ms + 26,00 ms
D: [alsa-sink-USB Audio] alsa-sink.c: Latency set to 26,00ms
D: [alsa-sink-USB Audio] alsa-sink.c: hwbuf_unused=348216
D: [alsa-sink-USB Audio] alsa-sink.c: setting avail_min=87848
D: [alsa-sink-USB Audio] alsa-sink.c: Requesting rewind due to latency change.
D: [alsa-sink-USB Audio] alsa-sink.c: Requested to rewind 352800 bytes.
D: [alsa-sink-USB Audio] alsa-sink.c: Limited to 351132 bytes.
D: [alsa-sink-USB Audio] alsa-sink.c: before: 87783
D: [alsa-sink-USB Audio] alsa-sink.c: after: 87783
D: [alsa-sink-USB Audio] alsa-sink.c: Rewound 351132 bytes.
D: [alsa-sink-USB Audio] sink.c: Processing rewind...
D: [alsa-sink-USB Audio] sink-input.c: Have to rewind 351132 bytes on render memblockq.
D: [alsa-sink-USB Audio] source.c: Processing rewind...
D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Core1.Stream added for object /org/pulseaudio/core1/playback_stream265
D: [alsa-sink-USB Audio] protocol-native.c: Requesting rewind due to end of underrun.
D: [alsa-sink-USB Audio] alsa-sink.c: Requested to rewind 352800 bytes.
D: [alsa-sink-USB Audio] alsa-sink.c: Limited to 4328 bytes.
D: [alsa-sink-USB Audio] alsa-sink.c: before: 1082
D: [alsa-sink-USB Audio] alsa-sink.c: after: 1082
D: [alsa-sink-USB Audio] alsa-sink.c: Rewound 4328 bytes.
D: [alsa-sink-USB Audio] sink.c: Processing rewind...
D: [alsa-sink-USB Audio] sink-input.c: Have to rewind 4328 bytes on render memblockq.
D: [alsa-sink-USB Audio] source.c: Processing rewind...
D: [alsa-sink-USB Audio] protocol-native.c: Implicit underrun of 'ALSA Playback'
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] alsa-sink.c: hwbuf_unused=0
D: [alsa-sink-USB Audio] alsa-sink.c: setting avail_min=87848
D: [alsa-sink-USB Audio] alsa-sink.c: Requested to rewind 352800 bytes.
D: [alsa-sink-USB Audio] alsa-sink.c: Limited to 2920 bytes.
D: [alsa-sink-USB Audio] alsa-sink.c: before: 730
D: [pulseaudio] module-suspend-on-idle.c: Sink alsa_output.usb-Logitech_Logitech_G930_Headset-00-Headset.iec958-stereo becomes idle, timeout in 5 seconds.
D: [alsa-sink-USB Audio] alsa-sink.c: after: 730
D: [alsa-sink-USB Audio] alsa-sink.c: Rewound 2920 bytes.
D: [alsa-sink-USB Audio] sink.c: Processing rewind...
D: [alsa-sink-USB Audio] source.c: Processing rewind...
D: [pulseaudio] module-suspend-on-idle.c: Sink alsa_output.usb-Logitech_Logitech_G930_Headset-00-Headset.iec958-stereo becomes idle, timeout in 5 seconds.
D: [pulseaudio] core.c: Hmm, no streams around, trying to vacuum.
D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Core1.Stream removed from object /org/pulseaudio/core1/playback_stream265
I: [pulseaudio] sink-input.c: Freeing input 265 "ALSA Playback"
I: [pulseaudio] module-stream-restore.c: Restoring device for stream sink-input-by-application-name:ALSA plug-in [FTL].
D: [pulseaudio] module-intended-roles.c: Not setting device for stream ALSA Playback, because already set.
I: [pulseaudio] sink-input.c: Trying to change sample rate
I: [pulseaudio] module-stream-restore.c: Restoring mute state for sink input sink-input-by-application-name:ALSA plug-in [FTL].
D: [pulseaudio] module-suspend-on-idle.c: Sink alsa_output.usb-Logitech_Logitech_G930_Headset-00-Headset.iec958-stereo becomes busy, resuming.
I: [pulseaudio] resampler.c: Forcing resampler 'copy', because of fixed, identical sample rates.
I: [pulseaudio] resampler.c: Using resampler 'copy'
I: [pulseaudio] resampler.c: Using s16le as working format.
D: [pulseaudio] resampler.c: Resampler:
D: [pulseaudio] resampler.c:   rate 44100 -> 44100 (method copy),
D: [pulseaudio] resampler.c:   format float32le -> s16le (intermediate s16le),
D: [pulseaudio] resampler.c:   channels 2 -> 2 (resampling 2)
D: [pulseaudio] memblockq.c: memblockq requested: maxlength=33554432, tlength=0, base=4, prebuf=0, minreq=1 maxrewind=0
D: [pulseaudio] memblockq.c: memblockq sanitized: maxlength=33554432, tlength=33554432, base=4, prebuf=0, minreq=4 maxrewind=0
I: [pulseaudio] sink-input.c: Created input 266 "ALSA Playback" on alsa_output.usb-Logitech_Logitech_G930_Headset-00-Headset.iec958-stereo with sample spec float32le 2ch 44100Hz and channel map front-left,front-right
I: [pulseaudio] sink-input.c:     media.name = "ALSA Playback"
I: [pulseaudio] sink-input.c:     application.name = "ALSA plug-in [FTL]"
I: [pulseaudio] sink-input.c:     native-protocol.peer = "UNIX socket client"
I: [pulseaudio] sink-input.c:     native-protocol.version = "28"
I: [pulseaudio] sink-input.c:     application.process.id = "1123"
I: [pulseaudio] sink-input.c:     application.process.user = "fabian"
I: [pulseaudio] sink-input.c:     application.process.host = "QUASAR"
I: [pulseaudio] sink-input.c:     application.process.binary = "FTL"
I: [pulseaudio] sink-input.c:     application.language = "C"
I: [pulseaudio] sink-input.c:     window.x11.display = ":0"
I: [pulseaudio] sink-input.c:     application.process.machine_id = "fd99aa52db0f4aa6b393c3b235eef24c"
I: [pulseaudio] sink-input.c:     application.process.session_id = "1"
I: [pulseaudio] sink-input.c:     module-stream-restore.id = "sink-input-by-application-name:ALSA plug-in [FTL]"
I: [pulseaudio] protocol-native.c: Requested tlength=40,00 ms, minreq=10,00 ms
D: [pulseaudio] protocol-native.c: Early requests mode enabled, configuring sink latency to minreq.
D: [pulseaudio] protocol-native.c: Requested latency=10,00 ms, Received latency=26,00 ms
D: [pulseaudio] memblockq.c: memblockq requested: maxlength=4194304, tlength=27520, base=8, prebuf=3528, minreq=9168 maxrewind=0
D: [pulseaudio] memblockq.c: memblockq sanitized: maxlength=4194304, tlength=27520, base=8, prebuf=3528, minreq=9168 maxrewind=0
I: [pulseaudio] protocol-native.c: Final latency 104,00 ms = 26,03 ms + 2*25,99 ms + 26,00 ms
D: [alsa-sink-USB Audio] alsa-sink.c: Latency set to 26,00ms
D: [alsa-sink-USB Audio] alsa-sink.c: hwbuf_unused=348216
D: [alsa-sink-USB Audio] alsa-sink.c: setting avail_min=87848
D: [alsa-sink-USB Audio] alsa-sink.c: Requesting rewind due to latency change.
D: [alsa-sink-USB Audio] alsa-sink.c: Requested to rewind 352800 bytes.
D: [alsa-sink-USB Audio] alsa-sink.c: Limited to 352544 bytes.
D: [alsa-sink-USB Audio] alsa-sink.c: before: 88136
D: [alsa-sink-USB Audio] alsa-sink.c: after: 87494
D: [alsa-sink-USB Audio] alsa-sink.c: Rewound 349976 bytes.
D: [alsa-sink-USB Audio] sink.c: Processing rewind...
D: [alsa-sink-USB Audio] sink-input.c: Have to rewind 349976 bytes on render memblockq.
D: [alsa-sink-USB Audio] source.c: Processing rewind...
D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Core1.Stream added for object /org/pulseaudio/core1/playback_stream266
D: [alsa-sink-USB Audio] protocol-native.c: Requesting rewind due to end of underrun.
D: [alsa-sink-USB Audio] alsa-sink.c: Requested to rewind 352800 bytes.
D: [alsa-sink-USB Audio] alsa-sink.c: Limited to 4328 bytes.
D: [alsa-sink-USB Audio] alsa-sink.c: before: 1082
D: [alsa-sink-USB Audio] alsa-sink.c: after: 1082
D: [alsa-sink-USB Audio] alsa-sink.c: Rewound 4328 bytes.
D: [alsa-sink-USB Audio] sink.c: Processing rewind...
D: [alsa-sink-USB Audio] sink-input.c: Have to rewind 4328 bytes on render memblockq.
D: [alsa-sink-USB Audio] source.c: Processing rewind...
D: [alsa-sink-USB Audio] protocol-native.c: Implicit underrun of 'ALSA Playback'
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] sink.c: Found underrun 2564 bytes ago (2020 bytes ahead in playback buffer)
D: [alsa-sink-USB Audio] alsa-sink.c: hwbuf_unused=0
D: [alsa-sink-USB Audio] alsa-sink.c: setting avail_min=87848
D: [alsa-sink-USB Audio] alsa-sink.c: Requested to rewind 352800 bytes.
D: [alsa-sink-USB Audio] alsa-sink.c: Limited to 4328 bytes.
D: [alsa-sink-USB Audio] alsa-sink.c: before: 1082
D: [alsa-sink-USB Audio] alsa-sink.c: after: 1082
D: [alsa-sink-USB Audio] alsa-sink.c: Rewound 4328 bytes.
D: [alsa-sink-USB Audio] sink.c: Processing rewind...
D: [alsa-sink-USB Audio] source.c: Processing rewind...
D: [pulseaudio] module-suspend-on-idle.c: Sink alsa_output.usb-Logitech_Logitech_G930_Headset-00-Headset.iec958-stereo becomes idle, timeout in 5 seconds.
D: [pulseaudio] module-suspend-on-idle.c: Sink alsa_output.usb-Logitech_Logitech_G930_Headset-00-Headset.iec958-stereo becomes idle, timeout in 5 seconds.
D: [pulseaudio] core.c: Hmm, no streams around, trying to vacuum.


Seems like it is a problem with alsa according to this
http://comments.gmane.org/gmane.comp.audio.pulseaudio.general/17484

According to the last post it should be fixed, since I have the latest version installed though it may not be, but I think here is not the place to discuss this issue.

Thank you for you time and help though boa13 ;)

Who is online

Users browsing this forum: No registered users and 9 guests