Startup Fail

Discuss problems related to FTL here. If you are having a problem or experiencing a bug PLEASE READ THE "MUST READ" POST.
Mazey
Posts: 4
Joined: Sun Jul 14, 2013 10:43 am

Startup Fail

Postby Mazey » Sun Jul 14, 2013 10:51 am

hey
i just bought ftl and tried to play it, but my pc freezes after 1/4th is loaded.
havent got logs of it because it freezes and i need to shut down my pc.
before buying, i checked the requirements and i should be able to run it.
im on linux mint 15

thanks, in advance.
boa13
Posts: 829
Joined: Mon Sep 17, 2012 11:42 pm
Location: Nantes, France

Re: Startup Fail

Postby boa13 » Mon Jul 15, 2013 6:01 am

What graphics card do you have? What graphics driver do you use? Which version?
Forum janitor — If you spot spam, PM me the URL and/or the username of the spammer.
I have powers, moderator powers. I am not keen on using them, but will do so if needed.
Mazey
Posts: 4
Joined: Sun Jul 14, 2013 10:43 am

Re: Startup Fail

Postby Mazey » Mon Jul 15, 2013 10:26 am

here a lspci

Code: Select all

00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03) <-----------
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03)
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express (rev 01)
03:01.0 CardBus bridge: Texas Instruments PCI6515 Cardbus Controller
03:01.5 Communication controller: Texas Instruments PCI6515 SmartCard Controller
03:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)


and have a sudo apt-cache policy xserver-xorg-video-intel

Code: Select all

xserver-xorg-video-intel:
  Installed: 2:2.21.6-0ubuntu4
  Candidate: 2:2.21.6-0ubuntu4
  Version table:
 *** 2:2.21.6-0ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ raring/main i386 Packages
        100 /var/lib/dpkg/status


here, a cat /var/log/Xorg.0.log | grep -i driver

Code: Select all

[    35.186]    X.Org Video Driver: 13.1
[    35.186]    X.Org XInput driver : 18.0
[    35.206] (==) Matched intel as autoconfigured driver 0
[    35.206] (==) Matched intel as autoconfigured driver 1
[    35.206] (==) Matched vesa as autoconfigured driver 2
[    35.206] (==) Matched modesetting as autoconfigured driver 3
[    35.206] (==) Matched fbdev as autoconfigured driver 4
[    35.206] (==) Assigned the driver to the xf86ConfigLayout
[    35.215] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    35.229]    Module class: X.Org Video Driver
[    35.229]    ABI class: X.Org Video Driver, version 13.1
[    35.230] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    35.230]    Module class: X.Org Video Driver
[    35.230]    ABI class: X.Org Video Driver, version 13.0
[    35.230] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    35.230]    Module class: X.Org Video Driver
[    35.230]    ABI class: X.Org Video Driver, version 13.1
[    35.231] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    35.231]    Module class: X.Org Video Driver
[    35.231]    ABI class: X.Org Video Driver, version 13.0
[    35.231] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
[    35.231] (II) VESA: driver for VESA chipsets: vesa
[    35.231] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    35.232] (II) FBDEV: driver for framebuffer: fbdev
[    35.237]    ABI class: X.Org Video Driver, version 13.1
[    36.634] (II) intel(0): [DRI2]   DRI driver: i915
[    37.153]    Module class: X.Org XInput Driver
[    37.153]    ABI class: X.Org XInput driver, version 18.0
[    37.153] (II) Using input driver 'evdev' for 'Video Bus'
[    37.159] (II) Using input driver 'evdev' for 'Power Button'
[    37.160] (II) No input driver specified, ignoring this device.
[    37.160] (II) Using input driver 'evdev' for 'Sleep Button'
[    37.162] (II) Using input driver 'evdev' for 'USB OPTICAL MOUSE'
[    37.163] (II) No input driver specified, ignoring this device.
[    37.163] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[    37.164] (II) Using input driver 'evdev' for 'DualPoint Stick'
[    37.165] (II) No input driver specified, ignoring this device.
[    37.166]    Module class: X.Org XInput Driver
[    37.166]    ABI class: X.Org XInput driver, version 18.0
[    37.166] (II) Using input driver 'synaptics' for 'AlpsPS/2 ALPS DualPoint TouchPad'


for you, a glxinfo | grep openGL

Code: Select all

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) 915GM x86/MMX/SSE2
OpenGL version string: 1.4 Mesa 9.1.3
OpenGL extensions:


if you want something else, just tell me the command.


ps: pls dont hack my pc cuz i gave u info :( :( :(
boa13
Posts: 829
Joined: Mon Sep 17, 2012 11:42 pm
Location: Nantes, France

Re: Startup Fail

Postby boa13 » Mon Jul 15, 2013 10:00 pm

Don't worry, I cannot hack your computer with the information you gave me. ;)

Unfortunately, it seems you are using an Intel chip, which have notoriously flaky driver support (especially with 3D). Your OpenGL information shows you have version 1.4 support in your driver. FTL requires at least version 2.0.

Besides, your computer appears to be quite old. The 915GM/GMS/910GML graphic chips, and the associated ICH6-M chipset, were first published in January 2005, more than 8 years ago.

I regret to inform you that it is unlikely that FTL will work on this computer. :(
Forum janitor — If you spot spam, PM me the URL and/or the username of the spammer.
I have powers, moderator powers. I am not keen on using them, but will do so if needed.
UltraMantis
Posts: 2141
Joined: Thu Sep 20, 2012 3:17 pm

Re: Startup Fail

Postby UltraMantis » Mon Jul 15, 2013 10:59 pm

Did you buy the game from this website?
Report spam using the handy Report Button Mod.
Mazey
Posts: 4
Joined: Sun Jul 14, 2013 10:43 am

Re: Startup Fail

Postby Mazey » Tue Jul 16, 2013 8:16 am

boa13 wrote:Don't worry, I cannot hack your computer with the information you gave me. ;)

Unfortunately, it seems you are using an Intel chip, which have notoriously flaky driver support (especially with 3D). Your OpenGL information shows you have version 1.4 support in your driver. FTL requires at least version 2.0.

Besides, your computer appears to be quite old. The 915GM/GMS/910GML graphic chips, and the associated ICH6-M chipset, were first published in January 2005, more than 8 years ago.

I regret to inform you that it is unlikely that FTL will work on this computer. :(


Thanks, well, I´m currently on a Dell Latitude D610 so I can expect stuff to not work, especially a lot of openGL stuff.
I´m going to buy a new one soon, though. Looking at the Lenovo G780 M84ADUK atm, I guess that will have an okay openGL version :)

UltraMantis wrote:Did you buy the game from this website?

Steam!
boa13
Posts: 829
Joined: Mon Sep 17, 2012 11:42 pm
Location: Nantes, France

Re: Startup Fail

Postby boa13 » Tue Jul 16, 2013 11:27 am

Mazey wrote:I´m going to buy a new one soon, though. Looking at the Lenovo G780 M84ADUK atm, I guess that will have an okay openGL version :)

With a dedicated NVIDIA card, it should work fine. ;)

I see that the laptop only has 1366x768 pixels, this is a bit low nowadays, but thankfully it is enough for FTL. FTL requires at least 1280x720.
Forum janitor — If you spot spam, PM me the URL and/or the username of the spammer.
I have powers, moderator powers. I am not keen on using them, but will do so if needed.

Who is online

Users browsing this forum: No registered users and 15 guests