Page 101 of 117

Problem with Python

Posted: Tue Jun 18, 2013 1:40 am
by mike9606
I have the supported version of python but it still says it can not detect Python. what Should I Do?

Re: Problem with Python

Posted: Tue Jun 18, 2013 8:16 am
by Dudemanjimonaship
mike9606 wrote:I have the supported version of python but it still says it can not detect Python. what Should I Do?

Here is a step-by-step all-in-one troubleshoot:
1. Extract files in the .zip file to where you want it to be
2. double-click main.py from the file explorer (not from your archive). A \cmd should come up with something about python and shortly after the mod loader will launch.
kthxbai ;)

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Posted: Thu Jun 20, 2013 6:16 pm
by TheOldCow
It says I need Python 2.7.3, and I have that exact version installed, what am I doing wrong? Please help!

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Posted: Thu Jun 20, 2013 6:59 pm
by kartoFlane
Double-click on main.py instead of modman.exe (it's broken)

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Posted: Thu Jun 20, 2013 7:10 pm
by TheOldCow
kartoFlane wrote:Double-click on main.py instead of modman.exe (it's broken)


I tried that, but all it does is flash a cmd on the screen for like half a second and then nothing happens!

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Posted: Fri Jun 21, 2013 4:11 am
by race421
when i run ftl with mods it works fine but when i press start game the game closes help

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Posted: Fri Jun 21, 2013 8:52 am
by kartoFlane
@TheOldCow
In GMM's directory, find the file named modman-log.txt and post its contents here. If it doesn't exist / is empty, try running the main.py via command line (so that we can see what it's saying before it terminates)

@race421
GMM works fine, but the mod you've installed (or combination thereof) causes the game to crash. Try to install mods one at a time to determine the culprit, and then just don't use that mod.

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Posted: Sun Jun 23, 2013 7:03 pm
by MeGusta90
I have python but it says I don't


Please help

I have the latest version and everything and I restarted my PC incase it was one of those programs where you gotta restart but it just keeps telling I don't have a supported version of python and the URL www.python.org/getit gives a 404

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Posted: Sun Jun 23, 2013 8:23 pm
by kartoFlane
Double click on main.py instead of modman.exe (it's broken)

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Posted: Mon Jun 24, 2013 12:22 am
by blargh555
Hey all. First of all, thank you Grognak for making this wonderful utility for installing mods. That being said, I seem to be having issues with that :( . First of all, I'm running a Mac on OS X 10.8.3 with Python 2.7, and my up-to-date FTL is on Steam (which I suspect is my problem). If I can't mod Steam FTL, is there a way to download a standalone version without repurchasing it? If Steam isn't the problem, I just need some help. Here is how I attempted to setup GMM:

- Unzip "Grognaks Mod Manager v1.7 Manix"
- As in the readme, I typed "chmod +x [GMM_FILEPATH]" (This returns nothing in Terminal)
- I then put all my mods in the "mods" folder
- Then I run modman.command, which returns this error:

Code: Select all

imac-c2d-2:~ MY_USERNAME$ /Users/MY_USERNAME/Desktop/Grognaks\ Mod\ Manager\ v1.7\ Manix/modman.command ; exit;
ERROR: dlopen(/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_tkinter.so, 2): no suitable image found.  Did find:
   /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_tkinter.so: no matching architecture in universal wrapper
Traceback (most recent call last):
  File "main.py", line 72, in <module>
    globals()[new_name] = __import__(old_name, globals(), locals(), [])
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-tk/Tkinter.py", line 39, in <module>
    import _tkinter # If this fails your Python may not be configured for Tk
ImportError: dlopen(/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_tkinter.so, 2): no suitable image found.  Did find:
   /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/_tkinter.so: no matching architecture in universal wrapper
logout

[Process completed]

(I replaced my name with "MY_USERNAME" for privacy's sake)

- Just to see if it will still work, I run main.py which sort of works. Some text in Terminal and the patch window appears, so I select my mods, and hit "Patch". It looks like it's going to work; Terminal returns that the mods are being installed but then this happens:

Code: Select all

imac-c2d-2:~ MY_USERNAME$ cd '/Users/MY_USERNAME/Desktop/Grognaks Mod Manager v1.7 Manix/' && '/usr/bin/pythonw'  '/Users/MY_USERNAME/Desktop/Grognaks Mod Manager v1.7 Manix/main.py'  && echo Exit status: $? && exit 1
INFO: Grognak's Mod Manager v1.7.0
INFO: Platform:    Darwin-12.3.0-x86_64-i386-64bit
INFO: Interpreter: CPython 2.7.2 (64bit)
INFO:
INFO: Rooting at: /Users/NY_USERNAME/Desktop/Grognaks Mod Manager v1.7 Manix
INFO:
INFO: Registering ctrl-c handler.
INFO: Using FTL dats path from config: /Users/MY_USERNAME/Library/Application Support/Steam/SteamApps/common/FTL Faster Than Light/FTL.app/Contents/Resources
INFO: Background hashing finished.
INFO:
INFO: Patching...
INFO:
INFO: Unpacking data.dat...
INFO: Unpacking resource.dat...
INFO:
INFO: Installing mod: Beginning Scrap.ftl
INFO: Merging folder: data
INFO:
INFO: Installing mod: Crystal Quest (start boost).ftl
INFO: Merging folder: data
INFO:
INFO: Installing mod: DronesPlus_0.7.7.ftl
INFO: Merging folder: data
INFO: Merging folder: img
INFO:
INFO: Installing mod: Extra Names Mod 1.1.ftl
INFO: Merging folder: data
INFO:
INFO: Installing mod: FTL-Additional-Events-and-Texts.ftl
INFO: Merging folder: data
INFO:
INFO: Installing mod: Highres Backgrounds V1.0.ftl
INFO: Merging folder: data
INFO: Merging folder: img
INFO:
INFO: Installing mod: UnlockedAugmentations_1.1.ftl
INFO: Merging folder: data
INFO:
INFO: Installing mod: Weaponanza v1.1.ftl
WARNING: Unsupported folder: __MACOSX
INFO: Merging folder: data
INFO: Merging folder: img
INFO:
INFO: Repacking data.dat
INFO: Listing files to pack...
INFO: Creating datfile...
INFO: Packing...
INFO:
INFO: Repacking resource.dat
INFO: Listing files to pack...
INFO: Creating datfile...
INFO: Packing...
INFO:
INFO: Patching succeeded.
ERROR: Unexpected exception in LogicThread.
Traceback (most recent call last):
  File "/Users/MY_USERNAME/Desktop/Grognaks Mod Manager v1.7 Manix/main.py", line 1130, in run
    self._process_event_queue(0.5)  # Includes some blocking.
  File "/Users/MY_USERNAME/Desktop/Grognaks Mod Manager v1.7 Manix/main.py", line 1159, in _process_event_queue
    self._process_event(action_name, arg_dict)
  File "/Users/MY_USERNAME/Desktop/Grognaks Mod Manager v1.7 Manix/main.py", line 1173, in _process_event
    self._patching_finished(arg_dict)
  File "/Users/MY_USERNAME/Desktop/Grognaks Mod Manager v1.7 Manix/main.py", line 1336, in _patching_finished
    ftl_exe_path = find_ftl_exe()
  File "/Users/MY_USERNAME/Desktop/Grognaks Mod Manager v1.7 Manix/main.py", line 894, in find_ftl_exe
    if (os.path.isfile(os.join(app_path, "Contents", "Info.plist"))):
AttributeError: 'module' object has no attribute 'join'
INFO:
INFO: Quitting... (ctrl-break to be rude)
INFO:
INFO: Bye
Exit status: 0
logout

[Process completed]


:(

If anyone knows what to do here, I would greatly appreciate any assistance. I tried to be as comprehensive in my report as possible, but if there's any other information missing, I will provide it. Thanks! :D

P.S. Sorry if there are spoiler tags, I am new to this forum and don't know how :(

P.P.S. Here's a recording of me attemping to set up GMM. Hope it helps.
https://www.dropbox.com/s/s45gghbbz113r ... 0Error.mp4