Serious probs

Discuss and distribute tools and methods for modding. Moderator - Grognak
Spearka
Posts: 20
Joined: Sat Jan 05, 2013 5:11 pm

Serious probs

Postby Spearka » Fri Feb 15, 2013 10:11 pm

I began deciding to make FTL ships through a combination of 2 ship editors, though after a bit of hard graft, for some reason, the game crashes, i have no idea why, i know it isn't a problem with system placement since they are all placed where they need to be, i know it isn't a problem with images since i have done ALL of the images including cloak, but it still crashes, i seriously don't know why so i would like your help as to why it is

Code: Select all

le crashlog
Version =  1.03.1

Stack Trace:

1 - 0x004d568b
2 - 0x004d6c40
3 - 0x004db118
4 - 0x00556f52
5 - 0x005585c2
6 - 0x00538488
7 - 0x00403ed0
8 - 0x0059b1af
9 - 0x00403f6a
10 - 0x00406a62
11 - 0x00407379
12 - 0x005d5ceb
13 - 0x005d5da8
14 - 0x005d5676
15 - 0x004010b6
16 - 0x00401128
UltraMantis
Posts: 2141
Joined: Thu Sep 20, 2012 3:17 pm

Re: Serious probs

Postby UltraMantis » Fri Feb 15, 2013 10:50 pm

Which ship editors?
Report spam using the handy Report Button Mod.
nataryeahbuddy
Posts: 176
Joined: Sun Jan 20, 2013 1:37 am

Re: Serious probs

Postby nataryeahbuddy » Fri Feb 15, 2013 10:52 pm

This is off topic, but its UltraMantis's 1000th post! I would be honored if you spend your 1001st post on one of my topics!
My most popular mod! Over 290 Downloads!
Advanced Weapons and Shields!
My second most popular mod! Over 240 Downloads!
Advanced Battle Systems!
An awesome ship with custom graphics and two new weapons!
F-22A Raptor for FTL
Spearka
Posts: 20
Joined: Sat Jan 05, 2013 5:11 pm

Re: Serious probs

Postby Spearka » Fri Feb 15, 2013 11:17 pm

UltraMantis wrote:Which ship editors?

tazardar's ship editor and standard FTLEdit, but i don't know whether that matters since i feel i synced it well
UltraMantis
Posts: 2141
Joined: Thu Sep 20, 2012 3:17 pm

Re: Serious probs

Postby UltraMantis » Fri Feb 15, 2013 11:47 pm

I don't know. From experience i know that unexpected crashes are fairly common and finding the problem can be very difficult. That is why i don't use ship editors. Doing it by hand makes it easier to trace back to an error. It looks like the problem is in one of the blueprints files, since errors with images usually result in things becoming invisible.

If you like you can upload the mod in it's current state so someone can take a look at it and help you find the problem.
Report spam using the handy Report Button Mod.
Spearka
Posts: 20
Joined: Sat Jan 05, 2013 5:11 pm

Re: Serious probs

Postby Spearka » Sat Feb 16, 2013 1:32 am

UltraMantis wrote:I don't know. From experience i know that unexpected crashes are fairly common and finding the problem can be very difficult. That is why i don't use ship editors. Doing it by hand makes it easier to trace back to an error. It looks like the problem is in one of the blueprints files, since errors with images usually result in things becoming invisible.

If you like you can upload the mod in it's current state so someone can take a look at it and help you find the problem.

data.rar

you will need to use a seperate img folder, i cannot attatch smaller files
UltraMantis
Posts: 2141
Joined: Thu Sep 20, 2012 3:17 pm

Re: Serious probs

Postby UltraMantis » Sat Feb 16, 2013 4:24 am

There's a few errors in the blueprints. I can't pin down which one caused the crashes.

Spaces in tags:

Code: Select all

<pilot power="1" room="0" start="true" img="room_pilot" />
<doors power="1" room="12" start="true" img="room_doors" />
normally it's:
<pilot power="1" room="0" start="true" img="room_pilot"/>
<doors power="1" room="12" start="true" img="room_doors"/>

Missing closing tags for certain systems:

Code: Select all

<medbay power="1" room="7" start="true" img="room_medbay"/>
   <slot>
      <direction>right</direction>
      <number>-2</number>
   </slot>
is incorrect. When slots are defined a closing tag must be included after the <slot> tag.
This is correct:
<medbay power="1" room="7" start="true" img="room_medbay">
   <slot>
      <direction>right</direction>
      <number>-2</number>
   </slot>
</medbay>

Note that the / is removed from the end of the opening <medbay> tag, and instead placed in the closing </medbay> tag. Systems with <slot> data are treated differently.

There's still some issues with room positions, but it's not crashing anymore. I don't know which editor messed up the data. It's a pretty serious error, maybe you should post about it in the editor thread.
Report spam using the handy Report Button Mod.
Spearka
Posts: 20
Joined: Sat Jan 05, 2013 5:11 pm

Re: Serious probs

Postby Spearka » Sat Feb 16, 2013 2:26 pm

UltraMantis wrote:There's a few errors in the blueprints. I can't pin down which one caused the crashes.

Spaces in tags:

Code: Select all

<pilot power="1" room="0" start="true" img="room_pilot" />
<doors power="1" room="12" start="true" img="room_doors" />
normally it's:
<pilot power="1" room="0" start="true" img="room_pilot"/>
<doors power="1" room="12" start="true" img="room_doors"/>

Missing closing tags for certain systems:

Code: Select all

<medbay power="1" room="7" start="true" img="room_medbay"/>
   <slot>
      <direction>right</direction>
      <number>-2</number>
   </slot>
is incorrect. When slots are defined a closing tag must be included after the <slot> tag.
This is correct:
<medbay power="1" room="7" start="true" img="room_medbay">
   <slot>
      <direction>right</direction>
      <number>-2</number>
   </slot>
</medbay>

Note that the / is removed from the end of the opening <medbay> tag, and instead placed in the closing </medbay> tag. Systems with <slot> data are treated differently.

There's still some issues with room positions, but it's not crashing anymore. I don't know which editor messed up the data. It's a pretty serious error, maybe you should post about it in the editor thread.

there is a very good chance it was FTLedit, i used it for the room layout and weapons (basically making the blueprint file) and the other creator for wepaon mounts, i noticed that when making the ship and adding stuff on options, the rooms would go horribly off position
Spearka
Posts: 20
Joined: Sat Jan 05, 2013 5:11 pm

Re: Serious probs

Postby Spearka » Sat Feb 16, 2013 7:10 pm

okay, i've managed to fix the room problems and a little off-center issue, but now the shield image is off-center and i do not know why, also, the outer doors (that are supposed to be airlocks to outside) don't drain oxygen, i do not knwo why this is and i cannot find the code to solve this
data.rar
User avatar
kartoFlane
Posts: 1479
Joined: Mon Jan 14, 2013 10:20 pm

Re: Serious probs

Postby kartoFlane » Sat Feb 16, 2013 10:10 pm

For shield graphic, you have to adjust the ellipse in shipname.txt - the latter two of the four values are the offset, try playing around with them to align the shield the way you want.

As for airlock doors not draining oxygen, it's an issue with their room IDs: airlock doors should have an ID of -1 where they border with space. Take a look at this, if you haven't seen it already; the room (left/up) and room (right/down) are the values you have to adjust.
Superluminal2 - a ship editor for FTL

Who is online

Users browsing this forum: No registered users and 37 guests