Macs & .ftl files: Fixing __MACOSX errors during GMM packing

Discuss and distribute tools and methods for modding. Moderator - Grognak
karmos
Posts: 16
Joined: Thu Jan 17, 2013 5:27 am
Location: elsewhere

Macs & .ftl files: Fixing __MACOSX errors during GMM packing

Postby karmos » Mon Jan 21, 2013 7:07 am

For those of us modding on macs:

If you are using OSX 10.3 or above, GMM will likely crash on you when you attempt to load your own .ftl files, giving you an error about an unsupported __MACOSX directory. This happens because OSX generates folders in .zip files when you create them. These folders then gum up GMM.

But there is a solution!

If you run

Code: Select all

zip -d filename.zip __MACOSX/\*
it will delete the generated __MACOSX directories. Upon being loaded as a .ftl file in GMM, it will re-pack and load smoothly.

I hadn't found this solution on the forums, so I thought this might be helpful.
Image
Current project: DronesPlus
Other mods: AugmentationsUnlocked
UltraMantis
Posts: 2141
Joined: Thu Sep 20, 2012 3:17 pm

Re: Macs & .ftl files: Fixing __MACOSX errors during GMM pac

Postby UltraMantis » Mon Jan 21, 2013 12:16 pm

That is an elegant solution. Cheers! :D
Report spam using the handy Report Button Mod.

Who is online

Users browsing this forum: No registered users and 6 guests