Search found 14 matches

by XiaoXiaoMan
Wed Jun 11, 2014 7:15 pm
Forum: Mod Development
Topic: Mod Testing Environment (1.2) (AE Compatible)
Replies: 57
Views: 80389

Re: Mod Testing Environment (1.2) (AE Compatible)

I tried to install my mod, MTE and the custom content patch, in that order, but all I keep getting is this:

Patching failed: java.util.NoSuchElementException: <findName> was set to require results but found none (/wrapper/findName(TESTBED_PICKRACE)/findLike/findLike/findName(TB_CCP_DUMMY)).
by XiaoXiaoMan
Sat Jun 07, 2014 7:54 pm
Forum: Technical Support and Bugs
Topic: Slug door hack event: killed crew, doors still disabled
Replies: 6
Views: 4609

Slug door hack event: killed crew, doors still disabled

http://cloud-4.steampowered.com/ugc/3260917931852729422/248222E76DF5DD979F328C27F8F463B2F8B9F492/ As you can see in the image linked above, I successfully disabled the Slug ship by killing the enemy crew. This was the event where your door system is disabled during the fight. Once the fight is over,...
by XiaoXiaoMan
Mon Sep 16, 2013 3:51 am
Forum: Mod Development
Topic: Adding new sectors
Replies: 47
Views: 18076

Re: Adding new sectors

Vhati wrote:Try kartoFlane's Error Checker again.
That extra closing tag may have caused it to miss things before.

The error checker found nothing of interest.
by XiaoXiaoMan
Mon Sep 16, 2013 12:36 am
Forum: Mod Development
Topic: Adding new sectors
Replies: 47
Views: 18076

Re: Adding new sectors

events.xml.append:XIAO_BOSS_FIGHT The last choice has an extraneous </event> closing tag. That could be bad. sector_data.xml.append:LEGION_SECTOR The closing tag's misspelled <sectorDescription>...</sectorDescrption>. But that's a common typo the game tolerates. In events.xml.append and events_ship...
by XiaoXiaoMan
Sun Sep 15, 2013 9:30 pm
Forum: Mod Development
Topic: Adding new sectors
Replies: 47
Views: 18076

Re: Adding new sectors

I took only a cursory glance, but I can't find anything wrong... That said, I'm not really well versed when it comes to sectors and events. Even in the previous problems that were resolved in this topic, I'm still not sure we've managed to pinpoint an exact cause, other than mistyped names... Try r...
by XiaoXiaoMan
Sun Sep 15, 2013 5:37 pm
Forum: Mod Development
Topic: Adding new sectors
Replies: 47
Views: 18076

Re: Adding new sectors

Hm. Can you post your new, fixed code / update the previous one? Also, read this , if you haven't already. Of course. autoBlueprints.xml.append <blueprintList name="SHIPS_LEGION"> <name>XIAO_FAT</name> <name>XIAO_MANTIS_SCOUT</name> <name>XIAO_MANTIS_FIGHTER</name> <name>XIAO_ROCK_FIGHTER...
by XiaoXiaoMan
Sun Sep 15, 2013 2:03 am
Forum: Mod Development
Topic: Adding new sectors
Replies: 47
Views: 18076

Re: Adding new sectors

Any number of stuff could go wrong, most commonly an event in one of the eventlLists used by the sector is mistyped. That said, verifying everything by hand is tedious, so instead I'll point you to this little error checking utility I wrote ... Your tool did help me find a few issues, but it's stil...
by XiaoXiaoMan
Sat Sep 14, 2013 2:18 am
Forum: Mod Development
Topic: Adding new sectors
Replies: 47
Views: 18076

Re: Adding new sectors

Using your tool, I spotted numerous problems that I was able to fix. ...But it still crashed.

This is getting frustrating.
by XiaoXiaoMan
Fri Sep 13, 2013 9:31 pm
Forum: Mod Development
Topic: Adding new sectors
Replies: 47
Views: 18076

Re: Adding new sectors

Nope, it still didn't work. What am I doing wrong? I just looked at the crashlogs, and most if not all appear to be the same: Version = 1.03.3 Stack Trace: 1 - 0x0047b515 2 - 0x005a0ef8 3 - 0x0069415b 4 - 0x004010fd 5 - 0x77bb9f72 RtlInitializeExceptionChain 6 - 0x77bb9f45 RtlInitializeExceptionChain
by XiaoXiaoMan
Fri Sep 13, 2013 7:49 pm
Forum: Mod Development
Topic: Adding new sectors
Replies: 47
Views: 18076

Re: Adding new sectors

blueprints.xml.append Just a misspelling, I hope? I don't know how smart FTL is about parsing XML files, but it'd be better to put events in events.xml, just to be sure. Typo on my part. I fixed it on my post. It's an append for events.xml, not blueprints.xml. <event name="START_BEACON_XIAO&qu...